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1. Introduction
Course authoring tool is an intuitive, highly integrated application for teaching material aggregation and editing. It allows the user to form the structure of a course, browse and select the activities from the resource pool and fill in the structure with appropriate examples and quizzes. The architecture supporting course authoring tool has a good support on multiple resource repositories, which is extremely convenient for future extending.
Software components:
· Front-end user-system interaction interface, the tool’s interface,
· Back-end communication APIs
· Back-end aggregates
· Back-end content providing applications (content brokering)

· The interface of the course authoring tool uses color cues and drag interaction methods to ease the process of editing. This part will be elaborated explained in the User Guide part. 

· Communication APIs provides the program interface for the JavaScript to use AJAX, which will allow the user to perform all the operations in one webpage.
· The content providing applications are the main access for course authoring tool to list out the available content for the user.

2. Installation

This chapter provides guidance to install course authoring tool in your designated server. To use course authoring tool, you have to get the aggregate database imported and the content providing application setup. The following introduction will not include the setup of aggregate database and content application.
1. IDE recommended: Eclipse (preferable to use Eclipse Kepler)

2. Download the source code of the authoring tool and the toolsuc (the login for the course-authoring) from this URL:
Authoring tool: https://github.com/PAWSLabUniversityOfPittsburgh/course-authoring
Toolsuc: https://github.com/PAWSLabUniversityOfPittsburgh/toolsuc
OR
Use the git link to import the source directly into the Eclipse

Authoring tool: https://github.com/PAWSLabUniversityOfPittsburgh/course-authoring.git
Toolsuc: https://github.com/PAWSLabUniversityOfPittsburgh/toolsuc.git
3. Find the config.xml file in folder: WebContent/WEB-INF/

<configuration>


<agg_dbstring>jdbc:mysql:[aggregate database URL] </agg_dbstring>


<agg_dbuser>[Username]</agg_dbuser>


<agg_dbpass>[Password]</agg_dbpass>

</configuration>

Put the correct URL, username and password in this file so that the app can access the database.

Similarly fill database info for the toolsuc folder in: src/main/webapp/WEB-INF/spring/dabase.xml
You will have to fill in the username and password for each bean element in the above file.

4. The course authoring tool is linked to the Tools User Control system, so that the access control part has to be removed.

WebContent/index.html

Delete line 24 so that the application will not send the verify information to user control system.
WebContent/script/course.authoring.js

Change the centralUrl variable’s value to any URL you like.

5. Tomcat installation:

Get the servers view panel: Windows > Show View > Others… > Click on Servers

In the server view panel, click on Add new Server > Select Tomcat v7.0 > give installation directory of your choice and install it

If you see a lot of errors in general in the project directory, do the following:

Right click on project directory > Build Path > Configure build Path > Click on Add Library > Server Runtime > Click Next and Select the Tomcat v7.0 and click Ok

6. Installing Maven: To install Maven, do the following:
Help > Install New Software… > Add

Name: m2e

Location: http://download.eclipse.org/technology/m2e/releases/1.0



7. Now the configuration is done, you can put the project into a web container and try it.
Right Click on the toolsuc > Run As > Run on Server

If the server is to be specified, click on Tomcat v7.0 and click Run.

3. The Interface
The authoring tool has 3 different panels, so the introduction of the interface will have 3 corresponding sections.
3.1 Course List Panel
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· In the course list panel, a list of all the courses in the aggregate database is shown for the user to select the desired one to edit.

· [Note] The first column is for the icon that shows if this course belongs to the current user. The blue icon with white letter “M” means that this course is owned by the current user. Only the owner can modify the parameters and the content of one course.
· Other columns including domain, course code, course name, created by, institution, created on, course id and #of groups show the brief information of one course. Each column can be ranked using the button in the head of the form.

· When there are many courses in the database, user can use the search box at the up-right corner to search for a specific course.

3.2 Course Info Panel (emerald)
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· When a specific course is selected from the course list panel, the user can open the course info panel to edit the meta-info of one course.
· The upper part of this panel is the section where user can change the course name, course code, domain and the visibility of one course. Clicking the save button, all the modification will be saved in the database.

· The lower part of this panel is the section where user can add, edit or delete resource for a course. In the left list, all the resources are shown. The user can drag the item in the list to change the sequence of this resource list. 3 different buttons below the list allow the user to edit, add and delete one resource.

· By clicking on the item in the resource list, the list right next to it will show the list of providers under this resource. And by clicking the trash can icon below the list, the user can delete a provider.

· The Available Providers list shows all the available providers, who supply enormous amount of quizzes and examples.
3.3 Topic Editing Panel
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· Topic editing panel has a Units list on the left, which shows all the units under this course. 3 buttons below the list allows the user to edit, add and delete one course.
· When a unit is selected, the right Resources part will show the activities under this unit in different resource tabs.
· The selected activities list on the left in one tab shows what activities the user has chosen to put in this unit. The trash can button provides the function to delete one activity from the list. By dragging the item in this list, the user can change the sequence of activities in this unit. By clicking on the Preview link on each item, the user can preview this activity in a new window.

· The right part in one tab is the activity pool. The user can select a specific author and use keywords to filter out desired activities. And the result will be shown in the Available Activities list. By dragging the item from this list to Selected Activities list, an activity will be added to this unit. Similarly, user can click on the Preview link embedded in one item to preview this activity.

3.4 Buttons at the bottom
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· These buttons can be accessed in every panel. Different buttons have different colors corresponding to different panels.

· By clicking on the Edit Topics button, the Topic Editing panel will open.
· 4 buttons to the right have functionalities at the level of courses. And their purposes are just the same as their caption.

4. Features

4.1 Add a course
Click on the button “New Course” at the bottom of the panel, a dialog will open up.
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· Fill in the course name, code, select a domain of the course and if this course is meant to be shown to others, check the box of “this course is visible”. Then click add button, a new course will be added into the system.

4.2 Edit a course’s Meta-info

· Select the desired course in the course list. And click on the “Edit course info” button at the bottom of the panel. This will open the “course info” panel.
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· The upper section of the panel is the area that displays the information of this course. Change them if you want and then click the save button. The new changes will be saved into the database.

4.3  Clone a course
· Select the desired course in the course list. And click on the “Clone course” button at the bottom of the panel. This will open the “clone this course” dialog.
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· Type the name and a new course that has all the same content as current one will be created in the database.
4.4 Delete a course

· Select the desired course in the course list. And click on the “Delete course” button at the bottom of the panel.
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· A dialog will show up for the user’s confirmation. Type in “DELETE” in the input box and then click “Delete” button, this course will be deleted.

4.5 Add a resource
· In the “course info” panel, click on the plus icon button under the resource list.
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· Type in the name of the new resource, then click the “Add” button, a new resource entry will be created under current course.

4.6 Edit a resource

· In the “course info” panel, select one resource to be edited, then click on the pencil icon button under the resource list.
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· Change the name of this resource into anything and click on the submit button, the update will be submitted to the database.
4.7 Delete a resource
· In the “course info” panel, select one resource to be deleted, then click on the trashcan icon button under the resource list.
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· A dialog will show up for the user’s confirmation. Type in “DELETE” in the input box and then click “Delete” button, all the information related to this resource will be removed from this course.

4.8 Add a provider into the resource
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· If a provider is needed to be added into a resource, select a resource from the list and then just drag an entry from the “Available Providers” list into the list to its right. For example, in this screenshot, a provider called “AnimatedExamples” was added to a resource.
4.9 Delete a provider
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· Select the provider to be deleted from the list and click the trashcan icon under the list. This provider will be deleted.

4.10 Add a unit

· In the “Topic Editing” panel, click the plus icon under the “Units” list.
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· Type in the name for the new unit in the dialog and then click the Add button, a new empty unit will be added under this course.
4.11 Edit a unit
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· Select one unit to be edited from the list, then click on the pencil icon button under the list.

Type in the new name for this unit in the dialog, then click Submit button to save the changes.

4.12 Delete a unit
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· Select the unit to be deleted from the list and click the trashcan icon under the list.
· A dialog will show up for the user’s confirmation. Type in “DELETE” in the input box and then click “Delete” button, all the content of this unit will be removed.

4.13 Find an activity from the pool

· Select on unit from the unit list, then select a resource tab to start to edit the content under this unit.
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· The user can select an author and type in keywords to search for activities. When the author and keywords are certain, a list of available activities will be fetched from a pool that is consisted of providers under this resource.

4.14 Add and delete an activity.
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· To add an activity, just drag an activity from the “Available Activities” list to the “Selected Activities” list.

To delete an activity, select it and then click the trashcan icon under the list. Then this activity will be deleted from this unit.

4.15 Preview an activity
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· By clicking the “Preview” link in one activity entry, a new dialog will open to show the content of this activity so that the user can determine if this activity fits this unit.
5 Interface Controller

· The interface is controlled by the JavaScript file course.authoring.js, with the help of jQuery and jQuery UI. This script file will create an object called “CA” in the runtime. In this chapter, this object will be explained in detail.
Object CA has the following members:

· actions: Object - this is the object that stores all the functions needed to produce the request to the server

· ajaxError: function (etype) - this is the function to handle the error during the ajax communication

· courseTable: Object - this is the object created by the data table plugin
· deploy: Object - this is the object that stores functions that deploy tabs and dialog boxes.
· format: Object - this is the object that stores functions that convert the data into correct format

· handlers: Object - this is the handler that will handle all the result got from the server

· outcomeValidation: function (actionName, rs) - this is the validator of the result got from the server

· receive: function (actionName, rs) - this is the function that actually do the receive procedure

· request: function (actionURL, args) - this is the function that actually send the request to the server
· view: Object - this is the object that stores all the functions related to view DOM manipulation

· wareHouse: Object - this is an object that stores the data received from the server

6 Content Brokering

· Content Brokering is the way the new content created by the authoring tools is bought to the Course Authoring.
· Webex Example Authoring, Quizjet authoring, Quizet authoring, Video Authoring or any other application that produces the content writes the content into the producer database (webex21 in this case). This new content written by the authoring tools now has to sync with the consumer application like Course Authoring.

· Content comes into the Course Authoring tool via the Content Brokering API in the form of JSON data.

· Below is the example of content from the Content Brokering API:

[image: image20.png]contentTypes: [

name: “annotated",





Currently the Course Authoring supports the following content types and content packages:

· Webex Examples: Java, Python, SQL, C, CPP, VB

· Animated Examples: Java, Python

· Parsons: Python

· Quizjet

· Quizpet

· Videos: Java, Python
· When a course is selected, click on the Course Info tab. There is a button called ‘Update Resources’ below the list of Providers. When the button is clicked, all the new content is updated into the aggregate database and hence into the Course Authoring application.
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